apt-get ? auto-remove? sbam!

 :: GNU/Linux :: Software

Andare in basso

apt-get ? auto-remove? sbam!

Messaggio Da lostpassword il Sab Gen 02, 2010 12:47 am

apt-get ha le traveggole:
Codice:
┌[lost@lost-ghost]
└[~]> sudo apt-get remove perl
Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libstdc++6-4.3-dev libstrigiqtdbusclient0 libcommons-collections3-java
  libclucene0ldbl libhsqldb-java-gcj gstreamer0.10-alsa evolution-common
  libcups2-dev libwine-alsa libwpd8c2a junit4 libqca2 libecj-java
  libcommons-pool-java apache2-utils lp-solve libgphoto2-port0 libepc-1.0-1
  gnome-desktop-data libtasn1-3-dev xfonts-scalable libgtop2-common
  libsensors3 libsensors4 gstreamer0.10-plugins-ugly libaudio-dev pkg-config
  libxine1-x libcaca0 openoffice.org-filter-mobiledev libsnmp15 genisoimage
  libdjvulibre21 djvulibre-desktop librdf0 xchat-common
  kdebase-runtime-data-common python-software-properties liblucene-java
  libilmbase6 libgpg-error-dev libsoundtouch1c2 libgda3-common network-manager
  libbtctl4 openoffice.org-java-common libcommons-el-java antlr
  x11proto-xinerama-dev libsilc-1.1-2 libbeecrypt6 comerr-dev
  update-manager-core libgfortran3 cupsddk app-install-data libbeagle1 libsane
  g++-4.3 junit libqt4-test unzip gnome-cards-data gthumb-data x11-xfs-utils
  libqt4-sql-mysql libqt4-dbus libwpg-0.1-1 x11proto-render-dev bsh-gcj
  python-gdata libgcrypt11-dev libnm-util0 liblircclient0 libxcb-xv0
  libcommons-modeler-java libjaxp1.3-java-gcj dvd+rw-tools libglu1-mesa
  libsane-extras libieee1284-3 libstlport4.6-dev lockfile-progs libapm1
  libopenspc0 libpisock9 libxi-dev libcamel1.2-11 kbuild
  libpt-1.10.10-plugins-alsa libapr1 update-notifier-common libxmu-headers
  libxrender-dev libtrackerclient0 libggzmod4 libqt4-core python-apt
  libantlr-java mysql-common libfftw3-3 mesa-common-dev totem-common ecj-gcj
  libservlet2.4-java libedata-cal1.2-6 kde-icons-oxygen libxine1-bin
  libpt-1.10.10 libkrb5-dev libsoup2.2-8 libsuitesparse-3.1.0 g++
  gnome-media-common librasqal0 pidgin-data libsoup2.4-1 libnss3-dev libgadu3
  libgphoto2-2 libqt3-compat-headers libtomcat5.5-java libpng12-dev
  exuberant-ctags libgalago3 libxerces2-java-gcj python-ipy libcdio7
  guile-1.8-libs libmysqlclient15off xfonts-75dpi libgnomekbd-common p7zip
  gedit-common ant-optional-gcj libhesiod0 libsoprano4 redland-utils libdmx1
  libgnome-pilot2 finger libxcursor-dev gettext libparted1.8-10
  libglibmm-2.4-1c2a ant libmusicbrainz4c2a libcommons-launcher-java arj
  xbitmaps dhcdbd libcommons-logging-java ecj bsh libexempi3
  libgnomeprint2.2-data libxine1-ffmpeg libgtksourceview2.0-common
  python-imaging libkpathsea4 librpm4.4 libijs-0.35 kdelibs5-data
  libglu1-mesa-dev libgnutls-dev libqtcore4 libwine x11proto-randr-dev
  gnome-backgrounds libegroupwise1.2-13 sudo python-xdg libwine-ldap libupnp3
  libjaxp1.3-java libnm-glib0 libgutenprint2 unattended-upgrades libggz2
  libxcb-shape0 libxmu-dev libgweather-common libecal1.2-7 libwxbase2.8-0
  libopenexr6 libjpeg62-dev libcrypto++7 libaa1 libwine-gphoto2
  docbook-xsl-doc-html rdesktop wodim libgdata1.2-1 libgtksourceview-common
  rsync libjline-java python-dbus libcommons-dbcp-java libnspr4-dev
  python-gnupginterface libxerces2-java virtualbox-ose-modules-2.6.26-2-486
  zlib1g-dev gnome-games-data libcdparanoia0 libgdata-google1.2-1
  python-pysqlite2 libqt4-sql libfreetype6-dev python-cupsutils xinit
  libebook1.2-9 libcommons-collections-java x11-session-utils libdv4
  libwine-print libwps-0.1-1 libopal-2.2 libcommons-beanutils-java
  libstreamanalyzer0 openprinting-ppds gstreamer0.10-plugins-bad
  libxalan2-java libfs6 libdvdread3 libedata-book1.2-2 libqt4-xml
  evolution-data-server xfonts-100dpi cdrdao libblas3gf libgnomevfs2-bin
  libxss1 tcl8.4 libqt3-headers xsane-common libcdaudio1 libedataserver1.2-9
  cupsddk-drivers libjasper1 libgtop2-7 libqt4-network libgeoip1 libperl5.10
  libgl1-mesa-dev liblcms1-dev liblapack3gf libwine-cms libwine-gl libsidplay1
  libxrandr-dev libxvmc1 libkadm55 zip python-gdbm python-cups libexpat1-dev
  libcommons-digester-java libnl1 dmz-cursor-theme python-4suite-xml
  liblua5.1-0 dmake libxklavier12 gnome-terminal-data libmeanwhile1 libgda3-3
  libsnmp-base filezilla-common libpq5 libpt-1.10.10-plugins-v4l
  libhsqldb-java libstreams0 pmount libraptor1 html2text libggzcore9 libgmyth0
  libzephyr3 amule-common libservlet2.3-java liblucene-java-doc gnuchess
  libjsch-java libvisual-0.4-0 libexif12 libqt4-script gstreamer0.10-gnomevfs
  libcupsys2 libmng-dev libecj-java-gcj ant-gcj evolution-data-server-common
  libaudio2 gimp-data libxcb-shm0 ant-optional libxinerama-dev
  gstreamer0.10-plugins-base desktop-file-utils kdebase-runtime-data
  libvte-common raptor-utils transmission-common libcupsys2-dev libaprutil1
  libantlr-java-gcj php5-common gstreamer0.10-tools lsb-release dpatch
  libwine-sane libmng1 libgnomeprintui2.2-common libofa0 libmpeg2-4
  libxalan2-java-gcj libmms0 libspeexdsp1 libneon27-gnutls libiptcdata0
  libgnomecups1.0-1 libpisync1 hplip-data libxine1-console libgdl-1-common
  liba52-0.7.4 gnome-vfs-obexftp
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  capplets-data cheese conky cowsay cups cups-driver-gutenprint debhelper
  defoma deskbar-applet desktop-base docbook-xml docbook-xsl dpkg-dev eclipse
  eclipse-cdt eclipse-common-nls eclipse-efj eclipse-gcj eclipse-jdt
  eclipse-jdt-gcj eclipse-jdt-nls eclipse-nls eclipse-pde eclipse-pde-gcj
  eclipse-pde-nls eclipse-platform eclipse-platform-gcj eclipse-platform-nls
  eclipse-rcp eclipse-rcp-gcj eclipse-rcp-nls eclipse-sdk eclipse-sdk-nls
  eclipse-source ekiga emesene eog epiphany-browser epiphany-extensions
  epiphany-gecko evince evolution evolution-exchange evolution-plugins
  evolution-webcal fast-user-switch-applet file-roller filezilla
  filezilla-locales flash-plugin fluxbox fontconfig fontconfig-config
  foomatic-db-engine foomatic-db-gutenprint foomatic-db-hpijs foomatic-filters
  foomatic-filters-ppds gappletviewer-4.3 gcalctool gcj-4.2 gcj-4.3
  gconf-editor gdm geany gedit ghostscript gimp git-core gitweb gjdoc gksu
  gnome-about gnome-app-install gnome-applets gnome-applets-data
  gnome-bluetooth gnome-control-center gnome-games gnome-icon-theme
  gnome-keyring gnome-media gnome-menus gnome-mount gnome-netstatus-applet
  gnome-nettool gnome-network-admin gnome-panel gnome-panel-data
  gnome-power-manager gnome-screensaver gnome-session gnome-settings-daemon
  gnome-spell gnome-system-monitor gnome-system-tools gnome-terminal
  gnome-themes gnome-themes-extras gnome-user-guide gnome-utils
  gnome-volume-manager gparted gs-common gsfonts gsfonts-x11
  gstreamer0.10-plugins-good gstreamer0.10-x gthumb gtk2-engines
  gtk2-engines-pixbuf gtkhtml3.14 gucharmap hal-cups-utils hardinfo hpijs
  hplip htdig iceweasel iceweasel-gnome-support iceweasel-l10n-it
  ijsgutenprint inkscape intltool-debian irssi java-gcj-compat
  java-gcj-compat-dev kdebase-runtime kdebase-runtime-bin-kde4 kdelibs-bin
  kdelibs5 kernel-package kerneloops khelpcenter4 ktorrent language-env
  libafterimage0 libavahi-ui0 libbonoboui2-0 libcairo-perl libcairo2
  libcairomm-1.0-1 libcompress-raw-zlib-perl libcompress-zlib-perl
  libdigest-hmac-perl libdigest-sha1-perl libedataserverui1.2-8 libeel2-2.20
  libepc-ui-1.0-1 liberror-perl libexchange-storage1.2-3 libfile-remove-perl
  libfontconfig1 libfontconfig1-dev libgail-common libgail18 libgcj8-1-awt
  libgcj8-dev libgcj8-src libgcj9-0-awt libgcj9-dev libgcj9-src libgd2-xpm
  libgdl-1-0 libgimp2.0 libgksu1.2-0 libgksu2-0 libgksuui1.0-1 libglade2-0
  libglib-perl libgnome-desktop-2 libgnome-media0 libgnome-window-settings1
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomebt0
  libgnomecanvas2-0 libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
  libgnomeprintui2.2-0 libgnomeui-0 libgpod3 libgraphviz4 libgs8
  libgtk-vnc-1.0-0 libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtkhtml2-0
  libgtkhtml3.14-19 libgtkmm-2.4-1c2a libgtksourceview1.0-0
  libgtksourceview2.0-0 libgtkspell0 libgucharmap6 libgweather1
  libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libio-compress-base-perl libio-compress-zlib-perl libio-stringy-perl
  libmagick++10 libmagick10 libmail-box-perl libmail-sendmail-perl
  libmailtools-perl libmetacity0 libmime-types-perl libnautilus-burn4
  libnautilus-extension1 libnet-dbus-perl libnotify1 libnss-mdns
  libobject-realize-later-perl liboobs-1-4 libpanel-applet2-0 libpango1.0-0
  libpango1.0-common libphonon4 libpoppler-glib3 libpoppler3 libpurple0
  libqt3-mt libqt3-mt-dev libqt4-designer libqt4-qt3support libqt4-svg
  libqtgui4 librsvg2-2 librsvg2-common libsexy2 libslab0 libspectre1
  libswfdec-0.6-90 libswt3.2-gtk-gcj libswt3.2-gtk-java libswt3.2-gtk-jni
  libsys-hostname-long-perl libtimedate-perl libtotem-plparser10 liburi-perl
  libuser-identity-perl libvte9 libwmf0.2-7 libwnck22 libwww-perl
  libwxgtk2.8-0 libxft-dev libxft2 libxine1 libxine1-misc-plugins
  libxine1-plugins libxml-parser-perl libxml-twig-perl liferea lm-sensors
  lxappearance metacity metacity-common module-assistant nautilus-data
  nautilus-sendto ndiswrapper-source netatalk network-manager-gnome
  notification-daemon openoffice.org openoffice.org-base
  openoffice.org-base-core openoffice.org-calc openoffice.org-core
  openoffice.org-dev openoffice.org-draw openoffice.org-evolution
  openoffice.org-gcj openoffice.org-gnome openoffice.org-gtk
  openoffice.org-help-en-us openoffice.org-help-it openoffice.org-impress
  openoffice.org-math openoffice.org-officebean
  openoffice.org-report-builder-bin openoffice.org-thesaurus-en-us
  openoffice.org-thesaurus-it openoffice.org-writer
  openoffice.org-writer2latex patchutils perl perl-modules phonon
  phonon-backend-xine pidgin po-debconf poppler-utils printconf python-cairo
  python-eggtrayicon python-foomatic python-glade2 python-gmenu python-gnome2
  python-gnome2-desktop python-gnome2-extras python-gtk2 python-gtkhtml2
  python-gtkmozembed python-gtksourceview2 python-notify python-sexy
  python-vte qt3-dev-tools qt4-qtconfig rarian-compat rhythmbox rpm rutilt
  rxvt-unicode seahorse serpentine sgml-base sgml-data software-properties-gtk
  sound-juicer swfdec-gnome swfdec-mozilla synaptic system-config-printer
  system-tools-backends terminator totem-gstreamer totem-mozilla totem-plugins
  transmission-gtk tsclient ttf-arphic-uming ttf-baekmuk ttf-bengali-fonts
  ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-devanagari-fonts
  ttf-gujarati-fonts ttf-indic-fonts ttf-kannada-fonts ttf-kochi-gothic
  ttf-liberation ttf-malayalam-fonts ttf-oriya-fonts ttf-punjabi-fonts
  ttf-sazanami-mincho ttf-tamil-fonts ttf-telugu-fonts update-manager
  update-notifier vinagre vino virtualbox-ose virtualbox-ose-source
  w3c-dtd-xhtml wine wine-bin wine-utils x-ttcidfont-conf x11-apps x11-utils
  xbase-clients xchat xml-core xorg xsane xterm xulrunner-1.9
  xulrunner-1.9-gnome-support yelp zenity
0 upgraded, 0 newly installed, 379 to remove and 1 not upgraded.
After this operation, 1765MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
┌[lost@lost-ghost] [1]
└[~]>
Ma che caz*o, io voglio rimuovere perl, e mi dice che quei pacchetti sono stati installati automaticamente e che *devono* essere rimossi? :O Sono una marea di pacchetti che mi servono, questo stron*o mi vuole fottere il computer. Pensate che se avessi usato aptitude remove perl, quel [Y/n] ? sarebbe diventato Y automaticamente, e mi sarei fottuto. Come risolvo sta cosa?
avatar
lostpassword

Messaggi : 95
Data d'iscrizione : 25.09.09
Località : Roma

Visualizza il profilo dell'utente http://lostpassword.hellospace.net

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da Slack il Sab Gen 02, 2010 1:01 am

Mi dispiace non conosco apt-get quindi non saprei aiutarti...
Però vorrei dire che avere un gestore di pacchetti è comodo ma come si può vedere non sempre non sempre capisce cosa vogliamo fare. Con Slackware per esempio non sarebbe mai capitata una cosa simile.
Era giusto per far capire a chi dice che "Slackware fa schifo perché non ha nemmeno un gestore di pacchetti" non a volte si sta meglio senza.
avatar
Slack

Messaggi : 248
Data d'iscrizione : 14.09.09
Località : /home/slack

Visualizza il profilo dell'utente http://linux.forumattivo.eu

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da lostpassword il Sab Gen 02, 2010 1:01 am

La rimozione manuale spesso(sempre, LOL) mi secca abbastanza.
avatar
lostpassword

Messaggi : 95
Data d'iscrizione : 25.09.09
Località : Roma

Visualizza il profilo dell'utente http://lostpassword.hellospace.net

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da floatman il Sab Gen 02, 2010 12:58 pm

Vuoi rimuovere perl da un sistema GNU/Linux....tu sei proprio pazzo -.-"
Fortuna che non hai usato il -y Very Happy
Non credere ai manuali di Perl del tipo: Perl è presente in *quasi* tutte le distro, è un eufemismo.
Ad esempio prendi LFS:
http://www.linuxfromscratch.org/lfs/view/6.5/index.html
tieni conto che non è BLFS ma quello minimale del manuale di base (alla sezione 6 vedi i pacchetti in ordine)
Rimuovere Perl vuol dire rimuovere l'interprete Shocked

Perchè lo volevi eliminare?
avatar
floatman

Messaggi : 844
Data d'iscrizione : 14.09.09

Visualizza il profilo dell'utente http://myville.altervista.org

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da vikkio88 il Sab Gen 02, 2010 1:01 pm

appunto..perhcè devi rimuovere perl?
avatar
vikkio88
Admin
Admin

Messaggi : 792
Data d'iscrizione : 14.09.09
Età : 29
Località : Palermo

Visualizza il profilo dell'utente http://vikkio88.altervista.org

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da Slack il Sab Gen 02, 2010 3:03 pm

Il perché secondo me conta meno, il problema e che apt-get gli vuole rimuovere un sacco di pacchetti in più...
Cioè se io voglio rimuovere un pacchetto perché il gestore nè vuole rimuovere molti altri?
avatar
Slack

Messaggi : 248
Data d'iscrizione : 14.09.09
Località : /home/slack

Visualizza il profilo dell'utente http://linux.forumattivo.eu

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da vikkio88 il Sab Gen 02, 2010 3:05 pm

perchè tutti quei pacchetti dipendono da quello che vuoi rimuovere e diventerebbero inutilizzabili se rimuovessi perl...quindi tantovale rimuoverli...
avatar
vikkio88
Admin
Admin

Messaggi : 792
Data d'iscrizione : 14.09.09
Età : 29
Località : Palermo

Visualizza il profilo dell'utente http://vikkio88.altervista.org

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da lostpassword il Sab Gen 02, 2010 7:31 pm

Sembra che il mio sistema sia perl-dipendente allora, LOL. Comunque, eliminato manualmente, e tutto funziona come prima. Al primo programma che richiede perl penso di esser costretto a reinstallarlo(sempre che non ci sia un programma alternativo che non lo richiede Very Happy), e per ora non ne ho bisogno. Il motivo della rimozione di perl e' che "mi sta sul *****". Non voglio piu' avermelo tra le pal*e.
avatar
lostpassword

Messaggi : 95
Data d'iscrizione : 25.09.09
Località : Roma

Visualizza il profilo dell'utente http://lostpassword.hellospace.net

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da floatman il Sab Gen 02, 2010 7:57 pm

# rm /usr/bin/perl
hai dato veramente questo comando -.-"
avatar
floatman

Messaggi : 844
Data d'iscrizione : 14.09.09

Visualizza il profilo dell'utente http://myville.altervista.org

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da Slack il Sab Gen 02, 2010 8:22 pm

Mi pare strano che ci siano cosi tanti pacchetti che dipendono da perl, sia gnome si tcl e molti altri...
avatar
Slack

Messaggi : 248
Data d'iscrizione : 14.09.09
Località : /home/slack

Visualizza il profilo dell'utente http://linux.forumattivo.eu

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da floatman il Dom Gen 03, 2010 12:36 am

Probabilmente vanno a catena con l'albero di apt.
Nel caso si dovrebbe andare a vedere, però ad esempio ti posto una cosa di cui sono sicuro:
http://packages.debian.org/lenny/gconf2
se guardi le dipendenze vedrai che c'è anche python, praticamente gconf si appoggia su python, quindi Gnome senza python perde metà delle sue funzionalità.
avatar
floatman

Messaggi : 844
Data d'iscrizione : 14.09.09

Visualizza il profilo dell'utente http://myville.altervista.org

Tornare in alto Andare in basso

Re: apt-get ? auto-remove? sbam!

Messaggio Da Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Tornare in alto

- Argomenti simili

 :: GNU/Linux :: Software

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum